Анонсирована готовность инфраструктуры для продления поддержки Debian 6 Squeeze до 2016 года

17 июня 2014 года

Wikinews-logo-ru.svg

Проект Debian объявил о готовности инфраструктуры для подготовки и распространения обновлений с устранением проблем безопасности для LTS-ветки Debian 6 Squeeze. Штатный срок поддержки Debian 6 истёк 31 мая 2014 года, но в рамках инициативы по применению расширенной поддержки (LTS) для прошлых стабильных веток (oldstable), связанные с безопасностью обновления будут выпускаться для Debian 6 до февраля 2016 года.

Таким образом время поддержки Debian Squeeze составит пять лет, что аналогично LTS-выпускам Ubuntu, но в два раза отстаёт от Red Hat Enterprise Linux и SUSE Linux Enterprise. Тем не менее, переход к более предсказуемому и не зависящему от активности разработки нового выпуска циклу поддержки дистрибутива, позволит заметно повысить привлекательность Debian в корпоративной среде. Если опыт окажется удачным, то практика формирования LTS-выпусков будет продолжена для Debian 7 ("wheezy") и Debian 8 ("jessie").

Выпуск обновлений для LTS-веток поручен отдельной группе разработчиков LTS Team, сформированной из энтузиастов и представителей компаний, заинтересованных в длительной поддержке Debian. Команда Debian security team продолжит работу без изменений и как и раньше будет отвечать за поддержку дистрибутива в рамках штатного цикла выпуска обновлений.

В рамках LTS-цикла обновления будут выпускаться только для архитектур i386 и amd64. Кроме того, длительный срок поддержки распространяется не на все пакеты, например, он не применим к web-приложениям для которых невозможно и нет смысла осуществлять поддержку в течение 5 лет (для продолжения использования таких пакетов рекомендуется задействовать бэкпорты). Проверить наличие в системе неподдерживемых пакетов можно при помощи утилиты check-support-status, входящей в состав пакета debian-security-support.

Для получения LTS-обновлений пользователям необходимо подключить в файле sources.list дополнительный репозиторий squeeze-lts - "deb http://http.debian.net/debian/ squeeze-lts main contrib non-free" (строки с ранее упоминаемым в конфигурации репозиторием squeeze нужно оставить как есть) и поменять в /etc/apt/apt.conf строку APT::Default-Release "squeeze" на APT::Default-Release "squeeze-lts".

 

ИсточникиПравить

Эта статья содержит материалы из статьи «Анонсирована готовность инфраструктуры для продления поддержки Debian 6 Squeeze до 2016 года», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots в архив и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:Анонсирована готовность инфраструктуры для продления поддержки Debian 6 Squeeze до 2016 года