В подсистеме ptrace ядра Linux обнаружена уязвимость, позволяющая поднять свои привилегии в системе

9 июля 2014 года

Wikinews-logo-ru.svg

В реализации системного вызова ptrace выявлена опасная уязвимость ( CVE-2014-4699), позволяющая поднять свои привилегии в системе. Уязвимость проявляется только на архитектуре x86_64 при использовании некоторых моделей CPU Intel. Проблема проявляется начиная с ядра 2.6.17, но техника эксплуатации для разных выпусков может отличаться. Для проверки наличия уязвимости опубликован рабочий прототип эксплоита.

Проблема вызвана отсутствием проверки корректности RIP-регистра в ptrace API, что при определённом стечении обстоятельств может привести к восстановлению некорректной точки возврата при использовании инструкции 'sysret'. Уязвимость уже исправлена в выпусках ядра Linux 3.15.4, 3.14.11, 3.4.97 и 3.10.47. Из дистрибутивов выпустивших обновление можно отметить Debian, Ubuntu и Arch Linux. Исправления пока не выпущены для CentOS, RHEL (проблема проявляется в RHEL 6/7, но не затрагивает RHEL 5), Fedora, openSUSE, SLES, Slackware, Gentoo.

 

ИсточникиПравить

Эта статья содержит материалы из статьи «В подсистеме ptrace ядра Linux обнаружена уязвимость, позволяющая поднять свои привилегии в системе», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots в архив и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:В подсистеме ptrace ядра Linux обнаружена уязвимость, позволяющая поднять свои привилегии в системе