Для Raspberry Pi 4 сертифицирована поддержка графического API Vulkan 1.0

26 ноября 2020 года

Wikinews-logo-ru.svg

Разработчики Raspberry Pi сообщили о сертификации организацией Khronos графического драйвера v3dv, который успешно прошёл более 100 тысяч тестов из набора CTS (Kronos Conformance Test Suite) и признан полностью совместимым со спецификацией Vulkan 1.0. Драйвер сертифицирован при использовании чипа Broadcom BCM2711, применяемого в платах Raspberry Pi 4, Raspberry Pi 400 и Compute Module 4. Проверка была выполнена на плате Raspberry Pi 4 с дистрибутивом Raspberry Pi OS на базе ядра Linux 5.4.51 и X-сервера.

Получение сертификата даёт возможность официально заявлять о совместимости с графическими стандартами и использовать связанные с ними торговые марки Khronos. Драйвер v3dv разработан компанией Igalia в сотрудничестве с организацией Raspberry Pi Foundation, в прошлом месяце был принят в основной состав Mesa и будет предложен в следующем релизе Mesa 20.3. По сравнению с OpenGL использование Vulkan позволяет добиться повышения производительности графических приложений и игр.

Драйвер v3dv ограничен поддержкой графического ускорителя VideoCore VI, применяемого начиная с модели Raspberry Pi 4. Для старых плат отдельно развивается драйвер RPi-VK-Driver, который реализует лишь подмножество API Vulkan, так как возможностей GPU VideoCore, поставлявшихся в платах до Raspberry Pi 4, недостаточно для полноценной реализации API Vulkan.

 

ИсточникиПравить


Эта статья содержит материалы из статьи «Для Raspberry Pi 4 сертифицирована поддержка графического API Vulkan 1.0», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:Для Raspberry Pi 4 сертифицирована поддержка графического API Vulkan 1.0