Доступен дистрибутив SUSE Linux Enterprise 15 SP3

24 июня 2021 года

<dynamicpagelist>

category = Опубликовано category = Компьютерные технологии notcategory = Не публиковать notcategory = Ожидаемые события по датам notcategory = Архивные новости notcategory=Викиновости коротко count = 18 stablepages = only suppresserrors = true namespace = Main addfirstcategorydate = true ordermethod = created </dynamicpagelist>

Wikinews-logo-ru.svg

После года разработки компания SUSE представила релиз дистрибутива SUSE Linux Enterprise 15 SP3. На основе платформы SUSE Linux Enterprise сформированы такие продукты, как SUSE Linux Enterprise Server, SUSE Linux Enterprise Desktop, SUSE Manager и SUSE Linux Enterprise High Performance Computing. Дистрибутив можно загрузить и использовать бесплатно, но доступ к получению обновлений и исправлений ограничен 60-дневным пробным периодом. Выпуск доступен в сборках для архитектур aarch64, ppc64le, s390x и x86_64.

В SUSE Linux Enterprise 15 SP3 обеспечена 100% бинарная совместимость пакетов с ранее выпущенным дистрибутивом openSUSE Leap 15.3, что позволяет максимально гладко переводить на SUSE Linux Enterprise системы, работающие под управлением OpenSUSE и наоборот. Предполагается, что пользователи могут вначале сформировать и протестировать рабочее решение на базе openSUSE, а затем переключиться на коммерческую версию с полноценной поддержкой, SLA, сертификацией, длительным выпуском обновлений и расширенными средствами для массового внедрения. Высокого уровня совместимости удалось добиться благодаря использованию в openSUSE единого с SUSE Linux Enterprise набора бинарных пакетов, вместо ранее практикуемой пересборки src-пакетов SUSE Linux Enterprise.

Основные изменения:

  • Как и в прошлом выпуске продолжена поставка ядра Linux 5.3, которое было расширено поддержкой нового оборудования. Добавлены оптимизации для процессоров AMD EPYC, Intel Xeon, Arm и Fujitsu, в том числе включены оптимизации, специфичные для процессоров AMD EPYC 7003. Добавлена поддержка PCIe-плат Habana Labs Goya AI Processor (AIP). Добавлена поддержка SoC NXP i.MX 8M Mini, NXP Layerscape LS1012A, NVIDIA Tegra X1 (T210) и Tegra X2 (T186).
  • Реализована поставка модулей ядра в сжатом виде.
  • Предоставлена возможность выбора режимов вытеснения (PREEMPT) в планировщике задач на этапе загрузки (preempt=none/voluntary/full).
  • Добавлена возможность сохранения дампов крахов ядра в механизм pstore, позволяющий сохранить данные в областях памяти, не теряемых между перезагрузками.
  • Повышен лимит на максимальное число файловых дескрипторов для пользовательских процессов (RLIMIT_NOFILE). Жёсткий лимит поднят с 4096 до 512K, а мягкий лимит, который может быть увеличен из самого приложения, оставлен неизменным (1024 дескриптора).
  • В firewalld добавлена поддержка бэкенда для использования nftables вместо iptables.
  • Добавлена поддержка VPN WireGuard (пакет wireguard-tools и модуль ядра).
  • В linuxrc обеспечена отправка DHCP-запросов в формате RFC-2132 без указания MAC-адреса для упрощения сопровождения большого числа хостов.
  • В dm-crypt добавлена поддержка шифрования в синхронном режиме, включаемом при помощи опций no-read-workqueue и no-write-workqueue в /etc/crypttab. Новый режим позволяет добиться повышения производительности по сравнению применяемым по умолчанию с асинхронным режимом.
  • Улучшена поддержка NVIDIA Compute Module, CUDA (Compute Unified Device Architecture) и Virtual GPU.
  • Добавлена поддержка предложенных во втором поколении процессоров AMD EPYC расширений виртуализации SEV (Secure Encrypted Virtualization), обеспечивающих прозрачное шифрование памяти виртуальных машин.
  • TLS 1.1 и 1.0 переведены в разряд не рекомендованных к применению. Поддержка данных протоколов может быть прекращена в одном из следующих выпусков. Поставляемые в дистрибутиве OpenSSL, GnuTLS и Mozilla NSS поддерживают TLS 1.3.
  • В состав включены пакеты exfatprogs и bcache-tools с утилитами для exFAT и BCache.
  • Добавлена возможность включения DAX (Direct Access) для отдельных файлов в Ext4 и XFS при помощи опции монтирования "-o dax=inode" и флага FS_XFLAG_DAX.
  • В утилиты Btrfs (btrfsprogs) добавлена поддержка сериализации (выполнение в порядке очереди) операций, которые не могут быть выполнены одновременно, такие как баласировка, удаление/добавление устройств и изменение размера ФС. Вместо вывода ошибки подобные операции теперь выполняются одна за другой.
  • В инсталляторе добавлены горячие клавиши Ctrl+Alt+Shift+C (в графическом режиме) и Ctrl+D Shift+C (в консольном режиме) для отображения диалога с дополнительными настройками (настройка сети, выбор репозиториев и переход в экспертный режим).
  • В YaST добавлена поддержка SELinux. Во время установки теперь можно включить SELinux и выбрать режим "enforcing" или "permissive". Улучшена поддержка скриптов и профилей в AutoYaST.
  • Предложены новые версии GCC 10, glibc 2.31, systemd 246, PostgreSQL 13, MariaDB 10.5, postfix 3.5, nginx 1.19, bluez 5.55, bind 9.16, clamav 0.103, erlang 22.3, NodeJS 14, Python 3.9, rust 1.43, flatpak 1.10, openssh 8.4, QEMU 5.2, samba 4.13, zypper 1.14.43, fwupd 1.5.
  • Добавлены JDBC-драйвер для PostgreSQL, пакеты nodejs-common, python-kubernetes, python3-kerberos, python-cassandra-driver, python-arrow, compat-libpthread_nonshared, librabbitmq
  • Как и в прошлом выпуске поставляется рабочий стол GNOME 3.34, в который перенесены накопившиеся исправления ошибок. Обновлены Inkscape 1.0.1, Mesa 20.2.4, Firefox 78.10.
  • В инструментарий управления сертификатами добавлена новая утилита xca (X Certificate and Key Management), при помощи которых можно создавать локальные удостоверяющие центры, создавать, подписывать и отзывать сертификаты, импортировать и экспортировать ключи и сертификаты в форматах PEM, DER и PKCS8.
  • Добавлена возможность использования инструментария для управления изолированными контейнерами Podman без привилегий root.
  • В NetworkManager добавлена поддержка IPSec VPN StrongSwan (требуется установка пакетов NetworkManager-strongswan и NetworkManager-strongswan-gnome). Объявлена устаревшей и может быть удалена в одном из будущих выпусков поддержка NetworkManager для серверных систем (для настройки сетевой подсистемы серверов используется wicked).
  • Пакет wpa_supplicant обновлён до версии 2.9 в которой появилась поддержка WPA3.
  • Расширена поддержка сканеров, пакет sane-backends обновлён до версии 1.0.32, в которой представлен новый бэкенд escl для сканеров, совместимых с технологией Airprint.
  • В состав включён драйвер etnaviv для GPU Vivante, используемых в различных ARM SoC, таких как NXP Layerscape LS1028A/LS1018A и NXP i.MX 8M. Для плат Raspberry Pi задействован загрузчик U-Boot.
  • В KVM максимальны размер памяти для виртуальной машины увеличен до 6 TiB. Гипервизор Xen обновлён до выпуска 4.14. libvirt обновлён до версии 7.0, а virt-manager до выпуска 3.2. В системах виртуализации без IOMMU реализована поддержка в виртуальных машинах более 256 CPU. Обновлена реализация протокола Spice. В spice-gtk добавлена поддержка монтирования iso-образов на стороне клиента, улучшена работа с буфером обмена и удалён бэкенд к PulseAudio. Добавлены официальные Vagrant Boxes для SUSE Linux Enterprise Server (x86-64 и AArch64).
  • Добавлен пакет swtpm с реализацией программного эмулятора TPM (Trusted Platform Module).
  • Для систем x86_64 добавлен обработчик простоя CPU - "haltpoll", который решает, когда можно перевести CPU в глубокие режимы экономии энергии, чем глубже режим - тем большая экономия, но и больше времени требуется для выхода из режима. Новый обработчик рассчитан на использование в системах виртуализации и позволяет используемому в гостевой системе виртуальному CPU (VCPU), запросить дополнительное время до перевода CPU в состояние idle. Подобный подход позволяет повысить производительность виртуализированных приложений за счёт предотвращения возврата управления гипервизору.
  • Объявлен устаревшим и будет удалён в SUSE Linux Enterprise 15 SP4 сервер OpenLDAP, вместо которого рекомендовано использовать LDAP-сервер 389 Directory Server (пакет 389-ds). Поставка клиентских библиотек и утилит OpenLDAP будет продолжена.
  • Объявлена устаревшей и будет прекращена в SUSE Linux Enterprise 15 SP4 поддержка контейнеров на базе инструментария LXC (пакеты libvirt-lxc и virt-sandbox). Вместо LXC рекомендовано использовать Docker или Podman.
  • Объявлена устаревшей поддержка скриптов инициализации System V init.d, которые будут автоматически сконвертированы в unit-ы systemd.
  • База данных пакетов RPM (rpmdb) переведена с BerkeleyDB на NDB (ветка Berkeley DB 5.x уже несколько лет не сопровождается, а переходу на более новые выпуски мешает изменение лицензии Berkeley DB 6 на AGPLv3, требования которой распространяются и на приложения, использующие BerkeleyDB в форме библиотеки - RPM поставляется под GPLv2, а AGPL несовместима с GPLv2).
  • Командная оболочка Bash теперь доступна как "/usr/bin/bash" (возможность вызова как /bin/bash сохранена).
 

ИсточникиПравить


Эта статья содержит материалы из статьи «Доступен дистрибутив SUSE Linux Enterprise 15 SP3», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:Доступен дистрибутив SUSE Linux Enterprise 15 SP3