Корректирующие релизы PostgreSQL: 9.1.1, 9.0.5, 8.4.9, 8.3.16 и 8.2.22

26 сентября 2011 года

Wikinews-logo-ru.svg

Доступны плановые корректирующие обновления для всех поддерживаемых веток PostgreSQL: 9.1.1 (11 исправлений), 9.0.5 (147 исправлений), 8.4.9 (96 исправлений), 8.3.16 (73 исправления) и 8.2.22 (52 исправлений). Релиз 8.2.22 является одним из последних в ветке PostgreSQL 8.2, поддержка которой будет прекращена в декабре. Поддержка PostgreSQL 8.3 продлится до февраля 2013 года, 8.4 - июля 2014 г., 9.0 - сентября 2015 г.

Из наиболее важных исправлений отмечены:

  • В contrib/pg_crypto внесены исправления проблем безопасности в библиотеке Blowfish, проявляющихся в понижении стойкости хэш-функции при использовании в тексте пароля восьмибитовых символов;
  • Обходной путь для ошибки в GCC 4.6.0, из-за которой наблюдаются проблемы при повторном наложении WAL-логов (например, при синхронизации базы на резервный сервер);
  • Устранена утечка памяти в коде сканирования GiST-индексов;
  • Улучшена обработка ошибок, возвращаемых в процессе использования SSL;
  • Устранены проблемы с работой команды VACUUM, связанные с обновлением содержимого pg_class.reltuples и pg_class.relpages;
  • Система планирования запросов теперь считает, что пустые родительские таблицы действительно пустые;
  • Запрещено выполнение SELECT FOR UPDATE/SHARE для последовательностей (sequences);
  • Устранен сбой, когда при выполнении DROP OWNED BY предпринималась попытка удаления принятых по умолчанию привилегий для последовательностей (sequences).
 

ИсточникиПравить


Эта статья содержит материалы из статьи «Корректирующие релизы PostgreSQL: 9.1.1, 9.0.5, 8.4.9, 8.3.16 и 8.2.22», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots в архив и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:Корректирующие релизы PostgreSQL: 9.1.1, 9.0.5, 8.4.9, 8.3.16 и 8.2.22