Обновление PHP 5.5.4

19 сентября 2013 года

Wikinews-logo-ru.svg

Представлен корректирующий выпуск интерпретатора языка программирования PHP - 5.5.4, в котором исправлено 17 ошибок.

Среди изменений:

  • В функцию fputcsv() добавлена возможность определения символа экранирования.
  • Устранены крахи при манипуляции объектами в cli/apache sap и при использовании zend_error() при сборке с опцией "--enable-dtrace".
  • В фильтре кодирования в quoted-printable исправлена некорректное кодирование пробелов. Исправлена неверная установка переменной PHP_BINARY. Устранены проблемы со сборкой в gcc 4.4.
  • Устранено переполнение буфера в модуле Datetime.
  • Налажена корректная инициализация идентификатора сессии при включенной поддержке защищённых сессий.
 

ИсточникиПравить


Эта статья содержит материалы из статьи «Обновление PHP 5.5.4», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots в архив и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:Обновление PHP 5.5.4