Обновление PostgreSQL 9.4.3, 9.3.8, 9.2.12, 9.1.17, 9.0.21

4 июня 2015 года

Wikinews-logo-ru.svg

Доступны корректирующие обновления для всех поддерживаемых веток PostgreSQL: 9.4.3, 9.3.8, 9.2.12, 9.1.17 и 9.0.21. Выпуск обновлений для ветки 9.0 продлится до сентября 2015 г., 9.1 до сентября 2016 г., 9.2 до сентября 2017 г., 9.3 до сентября 2018 г., 9.4 до декабря 2019 г. В новых выпусках устранена ошибка в реализации механизма fsync, которая может привести к невозможности запустить сервер после краха или восстановления из бинарной резервной копии. Проблема затрагивает конфигурации в которых в директории PGDATA размещены дополнительные файлы или директории, принадлежащие пользователю, отличному от "postgres", или недоступные на запись (подобное наблюдается в пакетах PostgreSQL 9.1 и 9.0 с SSL в Debian и Ubuntu). Если возник сбой с загрузкой PostgreSQL, обходным путём решения проблемы является временная смена прав доступа на недоступные на запись файлы в PGDATA на пользователя postgres.

 

ИсточникиПравить


Эта статья содержит материалы из статьи «Обновление PostgreSQL 9.4.3, 9.3.8, 9.2.12, 9.1.17, 9.0.21», опубликованной OpenNET и распространяющейся на условиях лицензии Creative Commons Attribution (CC BY) — указание автора, источник и лицензию.
Эта статья загружена автоматически ботом NewsBots в архив и ещё не проверялась редакторами Викиновостей.
Любой участник может оформить статью: добавить иллюстрации, викифицировать, заполнить шаблоны и добавить категории.
Любой редактор может снять этот шаблон после оформления и проверки.
 

Комментарии:Обновление PostgreSQL 9.4.3, 9.3.8, 9.2.12, 9.1.17, 9.0.21