Открыть главное меню

Android P больше не поддерживает старые приложения

29 марта 2018

Логотип Android P

Приложения, разработанные с API Android 4.1 (Jelly Bean) или более ранних версий, больше не будут поддерживаться в Android P. Это сообщили участники программы предварительного тестирования Android[1].

Если вы попытаетесь установить приложение, которое не работает с Android P, выдаётся следующее предупреждение: «Это приложение было создано для ранней версии Android и может работать некорректно. Проверьте, если ли обновления и обратитесь к разработчику».

Официальная документация заявляет[2], что «приложения, нацеленные на более низкие значения, не смогут установить и запустить», поэтому будет интересно посмотреть, как все это происходит в будущем.

Минимальная версия API, которую поддерживает Android P — это версия v17. Эта версия соответствует версии Android 4.2 Jelly Bean.

 

Примечания

Ссылки

Комментарии

Викиновости и Wikimedia Foundation не несут ответственности за любые материалы и точки зрения, находящиеся на странице и в разделе комментариев.